Forums/Slink/Troubleshooting

Plex video and music is not available via Slink

Olof Olsson
posted this on March 14, 2011 19:42

Symptom: you cannot access video and music in Plex from a Plex media server on your home network accessed via Slink.

Root cause

Due to a Plex bug, you can only access video and music from a single Plex media servers on your home network. If you have multiple Plex media servers, the Video and Music menus may not be available in Plex. Slinkware has logged this as a bug with Plex, and we are waiting for it to be fixed. The bug relates to the Plex app not honoring the port number that is advertised via Bonjour by the Plex media server. Instead Plex always uses the default port. As Slink provides services on localhost on a range of port numbers, only a single Plex media server can be used.

Workaround

The Plex bug means that you can only access a single Plex media server on your home network. If you have multiple Plex media servers on your home network, you must disable all the Plex media servers in Slink, except for the one you actually want to use. Do this by following these instructions:

1) Connect to your home network using Slink. All Plex servers show up in the Slink right hand services pane.

2) Right click on all the Plex servers you do not want to use and select Disable in the pop-up menu.

3) Ensure only a single Plex server is enabled.

4) Disconnect Slink and reconnect again.

You should now be able to use media from the single enabled Plex server.